[Rpm-ecosystem] rpm-4.14.0

Panu Matilainen pmatilai at redhat.com
Thu Oct 26 11:30:12 UTC 2017


On 10/26/2017 02:09 PM, Baho Utot wrote:
> 
> 
> On 10/26/17 00:34, Neal Gompa wrote:
>> On Wed, Oct 25, 2017 at 6:02 PM, Baho Utot <baho-utot at columbus.rr.com> 
>> wrote:
>>> When building on a raspberry-pi 2:
>>>
>>> tar xvf rpm-4.14.0.tar.bz2
>>> cd rpm-4.14.0
>>> tar ../db-4.5.20.tar.gz
>>> ln -s db-4.5.10 db
>>> ./autogen.sh --noconfigure
>>> ./configure --with-crypto=openssl --without-lua
>>> make
>>>
>>> Fails with file not found db.h
>>>
>>> When I do the same with rpm-4.13.0.1 it works as then configure stage
>>> creates db.h
>>
>> If those are actually your steps, I see at least two things wrong:
>>
>> 1. I think the minimum is BDB 4.8 (though BDB 5 is recommended)
>> 2. The symlink you're creating isn't valid, as the path is wrong.
>>
>>
> 
> 
> this also happens when using 6.0 and later also.
> 
> what is wrong with the symlink?  

As quoted in the above, earlier you wrote:

 >>> tar ../db-4.5.20.tar.gz
 >>> ln -s db-4.5.10 db

...and that cannot obviously work as the versions differ.

Anyway, the internal/external db logic changed somewhat in 4.14.0 (on 
purpose) but seems it doesn't automatically detect internal, which 
probably is not on purpose.

Adding --without-external-db to ./configure should make it work.

Also note that you don't need ./autogen.sh when building from release 
tarballs, that's only needed for building from a git clone.

	- Panu -


More information about the Rpm-ecosystem mailing list