[Rpm-ecosystem] Required version of rpm?
pmatilai at redhat.com
Tue Jun 26 13:57:10 UTC 2018
On 06/26/2018 04:46 PM, Miroslav Suchý wrote:
> Dne 26.6.2018 v 14:57 Panu Matilainen napsal(a):
>> On 06/26/2018 02:15 PM, Miroslav Suchý wrote:
>>> Dne 26.6.2018 v 12:17 Neal Gompa napsal(a):
>>>> rpmlib() dependencies are virtual, they aren't provided by anything,
>>>> but are processed during the transaction and verified.
>>> 1) So the number in rpmlib(RichDependencies) means what version of rpm I should have. Right?
>> Roughly yes, but beware there are cases where this is not true at all due to backports and sideports messing it all up.
> OK - corner cases and backports aside. But... I am still puzzled.
> $ rpm -qR redhat-rpm-config |grep Rich
> rpmlib(RichDependencies) <= 4.12.0-1
> So any rpm with verision *lower* than 4.12.0 will work? Should be there ">=" ?
Nope. From my previous email: "the version in rpmlib() dependencies is
sorta backwards to what people generally expect." - but it's the range,
not the version that appears backwards.
This is the way all rpmlib() dependencies have always been, here's the
best explanation I've found:
And in fact the rich dependency tracking version is a fine example of
how the version is not trustworthy: rich dependencies got added in
4.13.0, not 4.12.0 as the rpmlib() dependency would have you think.
>> Not that you'd want to go telling to upgrade their rpm beyond what their distro provides, that's a recipe for disaster.
> No, I do not want to do that. I just want to provide that user-friendly error.
- Panu -
> Rpm-ecosystem mailing list
> Rpm-ecosystem at lists.rpm.org
More information about the Rpm-ecosystem