[Rpm-ecosystem] Required version of rpm?

Miroslav Suchý msuchy at redhat.com
Thu Jun 28 08:06:01 UTC 2018


Dne 27.6.2018 v 19:56 Jeff Johnson napsal(a):
> The core problem is that the depsolver used by mock must be using bindings/libraries that implement rich dependencies, as well as metadata parsers that can represent rich dependencies.

Mock itself does not have any depsolving library or such capability. Everything is handled by YUM/DNF. The use-case of
install F28 on EL7 is probably lost as no one is going to add any new feature to YUM. But it is not not late to add it
to DNF/libdnf to handle future problems of installing e.g., F42 on EL8 :)

Miroslav


More information about the Rpm-ecosystem mailing list