RPM API dependency query

Vijay Tirumalai vijay.tirumalai at gmail.com
Sun Aug 30 21:19:21 UTC 2009

      I am using rpm-devel package 4.4.2-43.28 on a SLES server to develop
rpm API based application. I have implemented code using RPM API to upgarde
packages on a separate partition by implimenting the --relocate and --dbpath
option. I am encountering an error when I run my application trying to
upgrade a package. It complains of /bin/sh needed. I do not see the error if
I run the actual rpm command with the same options. I am not sure if I am
missing setting some other flags. /bin/sh exists. I have even tried running
my application by going into sh, but I still get the same error. One way I
could think of is to use the --nodeps flag. But I am not convinced that is
the right way as the actual rpm command works. Can anyone provide me some
pointers of what I might be doing wrong?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rpm.org/pipermail/rpm-list/attachments/20090830/c47b3917/attachment.htm>

More information about the Rpm-list mailing list