Found '/usr/src/redhat/BUILD/NetWatch-root' in installed files; aborting

Fulko Hew fulko.hew at
Fri Dec 4 15:49:45 UTC 2009

Following up on my own post...

On Fri, Dec 4, 2009 at 10:15 AM, Fulko Hew <fulko.hew at> wrote:

> I now,  all of a sudden :-)  I seem to be getting this error message when I
> build my package.
> I don't recall changing my spec file since the last time it worked
> properly,
> only adding some files 'inside' my package.
> I'm using a simple scenario, probably not the best/correct approach, but it
> basically is:
> a) develop the app in its target (installed) directory,
> b) when rpm-build'ing, copy the necessary files into the 'build' directory
> and continue.
> So I don't know what I'm doing wrong, the error message isn't helping me to
> understand
> what is going wrong, and I don't think I changed anything since the last
> time it worked.  :-)
> Can someone shed some light please.
> Fulko
> PS.  I'm building on a Fedora 8 box using RPM version

... snip ...

 I read all the related search-able stuff on the web that I could find, and
I found one
and I found one link that gave a clue, that said:

"Well, the problem is that a file in the package has the buildroot location
in it. This needs to be fixed."

So I thought what file do I have that has the string
'/usr/src/redhat/BUILD/NetWatch-root' in it?
My spec file doesn't, only the macro that would expand to it!
So I grep'ed everything and I found a 'typescript' log file lying around
that contained
the log of a previous build.  I guess I wanted to see all the steps that
were occuring during
the packaging.  Obviously this file didn't need to be part of my package, so
I deleted it.
Re-packaging now works fine.

Like other people before me, I was bewildered by what the error message was
trying to tell me...

   Found '/usr/src/redhat/BUILD/NetWatch-root' in installed files; aborting

Perhaps if it had hit me over the head with the following phrase instead, I
would have solved it faster:

   Found the not-allowed string '/usr/src/redhat/BUILD/NetWatch-root' in a
file in the package being created;  aborting

Thanks for listening
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Rpm-list mailing list