Adding rpm software to platform - cpio: MD5 sum mismatch when installing rpm's

Andy Furtado awf7d0 at
Tue Nov 9 18:44:27 UTC 2010


I'm adding the RPM software to our linux platform. It builds and almost appears 
to work but I'm seeing the following.

I'm having a problem with installing rpm's. More details are below but the most 
recent thing I've discovered is the call to NSS_NoDB_Init fails with -5925 
during RPMBUILD and RPM installs, so I'm wondering if this could be my problem. 

I've also tried installing a fairly simple rpm ...
rpm -ivv --nodeps nano-2.0.6-4.fc9.i386.rpm
But have the same checksum problem. 

Any help, or info on other resources would be greatly appreciated. 

Here are the details...
I'm having a problem installing an RPM that I created that only contains %files 
section to be installled on a i386 platform. 

The rpm database is currently empty so this is the first thing going in.

The problem is ...
  $ rpm -i /rpm/RPMS/i386/axis-4.0-1.i386.rpm 
error: unpacking of archive failed on file 
/device_handlers/axis/;4cd1a2a6: cpio: MD5 sum mismatch

What is actually being checksum'd during an install?

The target platform is based on FC10 but not a complete distribution.
I'm adding RPM to our platform, and the rpm source from rpm-4.6.1-3.fc10.src.rpm 
is built in an isolated build area using chroot. 

I'm also running rpm and rpmbuild from the same isolated build environment. 
My spec file is included  below.

I'd like to perform an rpm install in this same isolated area, but having the 
problem above. 

I believe I've satisfied all of the dependencies required, and manually 
verifying the md5sums have proven successful. 

My searches on the internet have found instances about incompatible libs needed 
for the packaged file but I don't think that is the case since I'm building 
everything against the same set of libs. I've also tried the prelink suggestions 
that I've found. 

I feel like maybe I'm missing something (executable) that rpm needs for the 

$ rpm -Kvv /rpm/RPMS/i386/axis-4.0-1.i386.rpm
D: loading keyring from pubkeys in /var/lib/rpm/pubkeys/*.key
D: couldn't find any keys in /var/lib/rpm/pubkeys/*.key
D: loading keyring from rpmdb
D: opening  db environment /var/lib/rpm/Packages cdb:mpool:joinenv
D: opening  db index        /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: Expected size:       458122 = lead(96)+sigs(120)+pad(0)+data(457906)
D:   Actual size:       458122
    MD5 digest: NOKEY
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages

Any information would be greatly appreciated.

Best Regards, 

Summary: Device Handler
Name: axis
Version: 4.0
Release: 1
License: GPL
BuildRoot:  /device_handlers/%{name}
BuildArch: i386

%define buildroot_dest %buildroot/device_handlers/%name


RPM to install handler.

mkdir -p %buildroot_dest
cp -rv %_builddir/%name/* %buildroot_dest


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Rpm-list mailing list