building a package that can not be upgraded

Stuart D Gathman stuart at bmsi.com
Wed Jul 18 01:45:00 UTC 2012


On Jul 17, Valery Reznic transmitted in part:

> Interesting example, but still here upgrade should be disable if some
> condition is true (or false :)
> Initial questions was how to disable it unconditionally and I wandered why
> one may want such a thing.

I think what the OP had in mind was a simple way to prevent auto-updating
with rpm -Fv *.rpm or rpm -Uv *.rpm, but still allow manual updating
with rpm -Uv --force problempackage.rpm


More information about the Rpm-list mailing list