cpio: Bad magic on ARM - (fixed)

David Hagood david.hagood at gmail.com
Tue Oct 30 11:29:56 UTC 2012

On 10/30/2012 02:01 AM, Panu Matilainen wrote:
> The first thing that comes to mind is payload compression which the
> ancient rpm-4.0.4 doesn't support.
And that was indeed the problem. The weird thing is that it 
sort-of-worked - it didn't just say "I don't like bzip2".
But that was the issue - changing the format to gzip solved the issue.

  That *should* cause dependency errors
> on attempted install though - are you installing with --nodeps?
No, I avoid using that. If you are going to ignore deps why use RPM in 
the first place?

> Upstream rpm defaults to backwards compatible settings, but eg RHEL 6
> and derivates (which have rpm-4.8.0) ship with XZ compression and
> SHA-256 file digests enabled, and you'll need to disable both at build
> time to have the resulting packages work on rpm 4.0.4, eg in the spec:
> %global _source_filedigest_algorithm 1
> %global _binary_filedigest_algorithm 1
Odd, but that wasn't necessary.

> %global _binary_payload w9.gzdio
> %global _source_payload w9.gzdio
Is there any good documentation on all these variables anywhere on 
rpm.org? I have not found any.

Thank you for the confirmation, and I will keep the digest issues in mind.

More information about the Rpm-list mailing list