Dependencies ignored with rpm install

Eran Ben Natan eranb at
Thu Jan 24 07:05:15 UTC 2013

OK. I tried to install A and B in the same rpm command and see the same
Thank you for clarifying this issue.

-----Original Message-----
From: rpm-list-bounces at
[mailto:rpm-list-bounces at] On Behalf Of James Antill
Sent: Wednesday, January 23, 2013 5:55 PM
To: rpm-list
Subject: Re: Dependencies ignored with rpm install

On Wed, 2013-01-23 at 14:38 +0200, Eran Ben Natan wrote:
> Hello all,
> I have a package B that requires A. When I run 'yum install B' and A 
> fails, B is installed anyway. Is this the right behavior? Can I change

> it?
> Running Transaction
> Error in PREIN scriptlet in rpm package A-1.0-1.x86_64
> error: %pre(A-1.0-1.x86_64) scriptlet failed, exit status 1
> error:   install: %pre scriptlet failed (2), skipping A-1.0-1

 This is a pure rpm thing, rpm doesn't undo parts of the transaction
when a prein scriptlet (or something else) fails.

Rpm-list mailing list
Rpm-list at

This mail was received via Mail-SeCure System.

More information about the Rpm-list mailing list