Handling name change of RPM

Steve Berg sberg at mississippi.com
Thu Jan 16 18:44:13 UTC 2014

Did you try "Obsolete" or "Obsoletes"?  According to https://fedoraproject.org/wiki/How_to_create_an_RPM_package it should be the latter, but that's not what you show in your email.

Steve Berg

----- Original Message -----
From: Sarang Radke [mailto:s.a.radke at gmail.com]
To: rpm-list at lists.rpm.org
Sent: Thu, 16 Jan 2014 10:37:10 -0800
Subject: Handling name change of RPM

Hi Folks,

I need to change the name of my RPM and it should override the RPM with old
name. However I am running into file conflict.

Old name - old-fw-1.0.0.noarch.rpm
New name - new-fw-2.0.0.noarch.rpm

Now when I try to install the new RPM with older RPM already installed, I
see a file conflict and installation fails. (tried # rpm -Uvh & -ivh)

What I have tried so far in the SPEC file is,

Obsolete: old-rpm
Conflicts: old-rpm
Provides: old-rpm

However the behavior was unchanged. Is there any way I can manage this thru
the SPEC file?

Please note: I don't want to ask users to use any other option like --force
or --replace-files. For them the change should be seamless.

Thank you in anticipation, any help is appreciated.


Rpm-list mailing list
Rpm-list at lists.rpm.org

More information about the Rpm-list mailing list