rpm setting group ids in installing a package

Seshwar Sehra t121xta at yahoo.com
Wed Mar 5 10:25:04 UTC 2014


Hi there,

I have an issue where if I install a package using the normal commands i have tried many options like below :

rpm -ivvh filename.rpm

The install goes through fine but I have an issue where the permissions for files are set fine but the groups are not getting set. The group is just always the same value for example test_op for all the files and folders. But then if I run the command rpm --setugids filename.rpm. the groups are then correctly set. I am not sure why this is not being set when I do the install but when i run the setugids commands it sets them perfectly fine ????

I have tried many things like using defattr and not setting file attributes mixing up ordering of where i use them etc. But nothing appears to work first time. 

The fact that it works once running setugids is telling me that the groups are being ignored on installing even though when i print the verbose output using -ivvh i can definitely see on the CREATE commands the groups values are shown correctly with the files being created. But when actually checking once installed they are not applied.

Please can i have some help on this matter?

Regards

Sesh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rpm.org/pipermail/rpm-list/attachments/20140305/aed8e285/attachment.html>


More information about the Rpm-list mailing list