What causes an installation of an rpm of a service to be in an enabled state (for systemd) ?

Kevin Wilson wkevils at gmail.com
Fri Mar 28 12:09:13 UTC 2014


I am trying to find what causes an installation of a Fedora rpm of some
service to
be in the "enabled" status for systemd (or "disabled" or "static").

More specifically:
Let's take a look in bluez-5.16-1.fc20.x86_64.rpm. When installing it,
I have F20 where the bluez rpm is not installed:

rpm -q bluez
package bluez is not installed
ls -al   /etc/systemd/system/bluetooth.target.wants
ls: cannot access /etc/systemd/system/bluetooth.target.wants: No such file
or directory

Now, I run
yum -y install bluez
And after it:

systemctl is-enabled bluetooth

ls -l   /etc/systemd/system/bluetooth.target.wants
total 0
lrwxrwxrwx 1 root root 41 Mar 28 15:03 bluetooth.service ->

rpm -qf  /etc/systemd/system/bluetooth.target.wants
file /etc/systemd/system/bluetooth.target.wants is not owned by any package

I tried to look inside the rpm what causes installation of the symlink
/etc/systemd/system/bluetooth.target.wants, and could not find.

Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rpm.org/pipermail/rpm-list/attachments/20140328/bdb764a7/attachment.html>

More information about the Rpm-list mailing list