Requires and ignore specific version
cristi.falcas at gmail.com
Sun Feb 22 12:43:25 UTC 2015
Is there any possibility to ignore a specific version for "Requires"?
We're trying to build a rpm for sprockets gem, which has this dependencies:
tilt (~> 1.1, != 1.3.0)
Is there any possibility to say something like this in the spec file:
Requires: rubygem(tilt) != 1.3.0
gem2rpm is generating this :
Requires: rubygem(tilt) > 1.3.0
Requires: rubygem(tilt) < 1.3.0
Which is turn makes the resulting rpm to depend on tilt<1.3.0 only (
we would like tilt 1.4.1 ).
More information about the Rpm-list