Requires and ignore specific version
cristi.falcas at gmail.com
Mon Feb 23 10:10:46 UTC 2015
On Mon, Feb 23, 2015 at 11:36 AM, Michael Mraka
<michael.mraka at redhat.com> wrote:
> Cristian Falcas wrote:
> % Hello,
> Hello Cristian,
> % Is there any possibility to ignore a specific version for "Requires"?
> There isn't an easy way to do this.
> % We're trying to build a rpm for sprockets gem, which has this dependencies:
> % sprockets (2.11.0)
> % ....
> % tilt (~> 1.1, != 1.3.0)
> % Is there any possibility to say something like this in the spec file:
> % Requires: rubygem(tilt) != 1.3.0
> % gem2rpm is generating this :
> % Requires: rubygem(tilt) > 1.3.0
> % Requires: rubygem(tilt) < 1.3.0
> % Which is turn makes the resulting rpm to depend on tilt<1.3.0 only (
> % we would like tilt 1.4.1 ).
> I'd simply use
> Requires: rubygem(tilt) > 1.3.0
> Michael Mráka
> Software Management Engineering, Red Hat
> Rpm-list mailing list
> Rpm-list at lists.rpm.org
More information about the Rpm-list