rpm83455 at rainslide.net
Tue Sep 15 09:40:20 UTC 2015
Hello. I am packaging some software of which a dependency is either Java 1.6.x or 1.7.x. The newer Java 1.8 won't work with it. It's not an option (yet) to update the software to work with the newer Java. Now that Java 1.8 is available, my current "Requires: java => 1.6.0" needs to be changed, because it could pull in 1.8.
I've looked everywhere online for a couple of days now. One suggestion was to have "Requires: >= 1.6.0, java < 1.8.0", but this does not work. I don't want to specify a specific version (eg., java = 184.108.40.206), because that might not be available on all platforms. So, my question is: how can we specify a required version greater than x and less than y?
Thank you in advance.
More information about the Rpm-list