rpm83455 at rainslide.net
Tue Sep 15 16:31:36 UTC 2015
On Tuesday, 15 September, 2015 at 16:59:57 BST, James Antill wrote:
>> Error: Package: foo (bar)
>> Requires: java < 1.8
>> You could try using --skip-broken to work around the problem
>> You could try running: rpm -Va --nofiles --nodigest
> Is this all it said? Does this machine have anything that provides
>"java < 1.8" ? This range should mostly work, apart from problems you'll
>hit post install where yum wants to upgrade java (assuming 1.8 is
>available) but the upgrade will fail.
Just before that, there were other messages telling me that Java 1.5, 1.6, 1.7, and 1.8 were available. Sorry for not including them in the output.
> The new OR rule is basically a simpler way of using virtual provides,
>so you can just do it the older more complex way:
>pkgA: Requires: pkgA-java-backend
>pkgA-java-backend16: Provides: pkgA-java-backend
> Requires: java = 1.6
>pkgA-java-backend17: Provides: pkgA-java-backend
> Requires: java = 1.7
>...of course you'll still hit the upgrade problem.
I really don't want to cause any problems in future. Maybe I'll just document that one has to have 1.6 or 1.7 installed already, before installing my package. It could be a limitation we'll live with until we can update support for 1.8.
More information about the Rpm-list