<html><head></head><body><div style="color:#000; background-color:#fff; font-family:HelveticaNeue, Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif;font-size:16px"><div id="yui_3_16_0_ym18_1_1459784957322_36212"><span id="yui_3_16_0_ym18_1_1459784957322_36256">Thank you.  Unfortunately, the package has already been created.  Is there anyway to turn off %pretrans from being executed in an already built package?</span></div> <div class="qtdSeparateBR"><br><br></div><div class="yahoo_quoted" style="display: block;"> <div style="font-family: HelveticaNeue, Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif; font-size: 16px;"> <div style="font-family: HelveticaNeue, Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif; font-size: 16px;"> <div dir="ltr"><font size="2" face="Arial"> On Monday, April 4, 2016 5:45 PM, Thierry Vignaud <thierry.vignaud@gmail.com> wrote:<br></font></div>  <br><br> <div class="y_msg_container">On 4 April 2016 at 19:48, doc <<a shape="rect" ymailto="mailto:drplastic99@yahoo.com" href="mailto:drplastic99@yahoo.com">drplastic99@yahoo.com</a>> wrote:<div class="yqt8636108767" id="yqtfd24686"><br clear="none">> The %pretrans: is a leftover from when others were creating the package.<br clear="none">> It was never an issue until KS.<br clear="none">><br clear="none">> - What version of RHEL is used?<br clear="none">>    CentOS 6.7<br clear="none">><br clear="none">> - What's the actual failure?<br clear="none">>    The failure appears to be that on a bare metal machine, KS runs the<br clear="none">> pretrans before /bin/sh is installed.  Are the dependencies checked for<br clear="none">> before or after the %pretrans is executed?<br clear="none">><br clear="none">> - What's the actual error message?<br clear="none">><br clear="none">> error: %pretrans(noop-0.0.1.GA-1.x86_64) scriptlet failed,<br clear="none">> exit status 127<br clear="none">><br clear="none">> - Is that the whole %pretrans ?<br clear="none">><br clear="none">> %pretrans<br clear="none">> [ -n "$VERBOSE" ] && set -x ; :<br clear="none">><br clear="none">> %post</div><br clear="none"><br clear="none">So rpm is too old for pretrans requires...<br clear="none">Anyway, this %pretrans is useless: the set -x won't affect anything else<br clear="none">Just drop it.<div class="yqt8636108767" id="yqtfd54421"><br clear="none"></div><br><br></div>  </div> </div>  </div></div></body></html>