[Rpm-maint] What provides rpmlib(PayloadIsLzma)?

Jindrich Novy jnovy at redhat.com
Tue Aug 5 06:39:38 UTC 2008


On Tue, Aug 05, 2008 at 10:27:23AM +0800, holmes86 wrote:
> I am update glibc and it requires rpmlib(PayloadIsLzma) be installed. What rpm do this library belong?
> as follows:
> error: Failed dependencies:
>         rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by glibc-2.8-1.i686
>         rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by glibc-common-2.8-1.i686
>         rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by glibc-devel-2.8-1.i686
>         rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by glibc-headers-2.8-1.i686
>         rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by glibc-utils-2.8-1.i686
> My rpm version is
> thanx

it seems like you are installing a package that uses LZMA compressed
payload with RPM that still doesn't support it. Older RPMs support
only gz and bz2 payload compressions. This is typically a case when 
you are installing new SuSE package to Fedora/Mandriva system.

Similar problems may occur in the future because of the LZMA format
change. Currently there exist two of them, the old one without magic
numbers in the beginning and the new one with magic.

Upstream RPM supports only new LZMA file format because it is very
hard to determine a file format without magic and also because IIRC
LZMA upstream tends to support only the newer format as soon as the
lzma-4.42 becomes stable. From my testing, 4.42.3alpha still has
problems with expanding large archives. But hopefully LZMA guys will
finish stabilizing 4.42 soon so that it could be enabled by default in
downstream distros.


Jindrich Novy <jnovy at redhat.com>   http://people.redhat.com/jnovy/

More information about the Rpm-maint mailing list