[Rpm-maint] RPM GPG keys

aneeskA aneeska2k5 at gmail.com
Wed May 28 10:46:07 UTC 2008

see the problem i was faced was this:- i created keys. i signed the rpms
with those keys. but when i try to install those rpms using 'yum
localinstall' it failed asking for the key. now the next possible step would
be to install the key. i had no idea where the key was. i tried checking
inside the folder '.gnupg' in my home folder and found none. i tried all
sorts of things with the contents found inside that but to no good. may be i
didnt read the documentation clearly. i never found the nexessary info in
that page how to export the key. only in
http://www.gnupg.org/gph/en/manual.html i found it. thats why i said so.

-- anees

On Wed, May 28, 2008 at 4:06 PM, Panu Matilainen <pmatilai at redhat.com>

> On Wed, 28 May 2008, aneeskA wrote:
>  HI Panu,
>>     I tried that link before i sent the mail. This one is more useful and
>> it had the answer to my question.
>> http://www.gnupg.org/gph/en/manual.html
> Erm, the fine gnupg manual tells you a lot of things but it does NOT tell
> you how to import a key into rpmdb for verifying packages with rpm/yum.
> Which, as far as I can tell, was the question here:
>          i created a pair of RSA keys using 'gpg' and signed
>>      the rpms using
>>      this key. when i try to install the rpm on another or
>>      even in my machine
>>      using yum localinstall it says no key installed. i dont
>>      want to bypass
>>      the key check. how can i solve this problem? which is
>>      the file that would serve as the key ? Please help
>        - Panu -
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rpm.org/pipermail/rpm-maint/attachments/20080528/a8fb3463/attachment-0001.htm 

More information about the Rpm-maint mailing list