[Rpm-maint] [PATCH] re-factoring rpmInstall & rpmErase - merging common code & removing redundancy
rakesh.pandit at gmail.com
Tue Feb 10 17:48:54 UTC 2009
2009/2/10 Panu Matilainen wrote:
> On Thu, 15 Jan 2009, Rakesh Pandit wrote:
>> - Merge rpmInstallInterfaceFlags_e and rpmEraseInterfaceFlags_e to
>> - Renamed (UN)?INSTALL_* to RPMCLI_* and all corresponding changes in
>> different interface related files.
> As we've talked (outside list), finding a good name for these things seems
> to be almost the hardest part here, silly as it is. The problem with "cli"
> for these flags is that it's *too* generic.
> How about just merge rpmInstallInterfaceFlags_e and rpmEraseInterfaceFlags_e
> to rpmInstallFlags_e? Obviously erasing isn't installing, but it's at least
> in the ballpark.
Very much right.
>> Second patch:
>> - Merged installInterfaceFlags and eraseInterfaceFlags into
> ..and the same here, if we just follow what query verify etc do here, just
> call it 'rpmcliInstallFlags'.
>> - Moved transaction part from rpmInstall and rpmErase to
> I'd suggest leaving rpmCliTransaction() static for now, just to have the
> freedom of changing it's arguments if that becomes necessary later on. As
> long as rpmqv.c is using rpmInstall() and rpmErase(), rpmCliTransaction()
> doesn't need exporting.
> Oh and rpmcliTransaction() (vs rpmCli...) would be more in line with the
> other cli-related things like rpmcliQuery(), doesn't of course matter if
Yes, to keep consistency. Fixed.
>> Third patch :
>> -Remove stopinstall variable and moved rpmcliPackagesTotal to correct
>> -Changes in rpmInstallSource for getting reused in install mode and
> Looks ok to me.
Updated first two. All three are here:
More information about the Rpm-maint