[Rpm-maint] [PATCH] Moved manifest checking from rpmInstall to rpmCheckManifest
pmatilai at redhat.com
Thu Feb 12 08:57:17 UTC 2009
On Tue, 20 Jan 2009, Rakesh Pandit wrote:
> Moving out parts which can be logically separated slowly out of
> rpmInstall. That will make this beast function more clean,
> maintainable and at some point we can untangle the complex flow it
> uses (using labels) to simple algorithm giving us some chance to think
> about solving some more complex big issues ;)
> Comments and suggestions ?
That's one possible split (but something like tryReadManifest() would be
better name than "check manifest), another possibility might be splitting
out both the package and manifest reading to another function?
Which reminds me... rpmgi.c has bits and pieces to do pretty much just
that. AFAIK the idea behind introducing rpmgi.c has been to unify the
file+manifest handling in both install and erase operations, it just was
never finished so we have query code using rpmgi and install code
duplicating a lot of the same. OTOH rpmgi is a dragon of its own :) but
maybe something to look into. Doesn't mean we can't clean up rpmInstall()
by other means first, switching to use rpmgi might well be easier once the
rpmInstall() blob is chopped to smaller pieces.
- Panu -
More information about the Rpm-maint