[Rpm-maint] [PATCH] Moved manifest checking from rpmInstall to rpmCheckManifest
pmatilai at redhat.com
Thu Feb 12 09:47:02 UTC 2009
On Thu, 12 Feb 2009, Rakesh Pandit wrote:
> 2009/2/12 Panu Matilainen wrote:
>> On Tue, 20 Jan 2009, Rakesh Pandit wrote:
>> That's one possible split (but something like tryReadManifest() would be
>> better name than "check manifest), another possibility might be splitting
>> out both the package and manifest reading to another function?
> Yeah .. will update.
>> Which reminds me... rpmgi.c has bits and pieces to do pretty much just that.
>> AFAIK the idea behind introducing rpmgi.c has been to unify the
>> file+manifest handling in both install and erase operations, it just was
>> never finished so we have query code using rpmgi and install code
>> duplicating a lot of the same. OTOH rpmgi is a dragon of its own :) but
>> maybe something to look into. Doesn't mean we can't clean up rpmInstall() by
>> other means first, switching to use rpmgi might well be easier once the
>> rpmInstall() blob is chopped to smaller pieces.
> In case it okay I would like to follow later approach (... fight with
> two dragons separately ;) i.e chop rpminstall into pieces (even try to
> simultaneously kill as much as repeated stuff, but preference being to
> get the complex rpmInstall ease a bit) But once it is done we can kill
> the duplication easily.
Sure. The rpmgi mumbling was just to make you aware of the sibling
- Panu -
More information about the Rpm-maint