[Rpm-maint] [PATCH 10/19] Add new policy requires tag to spec file format
james at fedoraproject.org
Fri Feb 5 17:33:44 UTC 2010
On Tue, 2010-02-02 at 15:25 -0500, Steve Lawrence wrote:
> The PolicyRequires tag is used to specify which versions of packages are
> required by policies installed in the module. The PolicyRequires tag has
> the same syntax as the Requires tag.
> Assume libselinux-1.2 is installed on the system. Package foo-1.0 has a
> policy module that 'Requires: libselinux >= 1.3'. Running the command:
> rpm -Uvh foo-1.0.rpm libselinux-1.3.rpm
> would meet all normal dependencies. However, the policy installation
> would still fail because a policy module in foo requires a newer version
> of libselinux than is on the system at the time of policy installation
> (at the beginning of the transaction). The solution would be to install
> the packages in two separate transactions:
> rpm -Uvh libselinux-1.3.rpm
> rpm -Uvh foo-1.0.rpm
> However, this is unintuitive and not always possible.
> The new PolicyRequires directive solves this problem.
Again, IMNSO, this just argues for making real "policy only" packages,
and then prco data will just work.
James Antill - james at fedoraproject.org
More information about the Rpm-maint