[Rpm-maint] Support "magic_and_path" flag in fileaattrs
pmatilai at laiskiainen.org
Tue May 17 13:00:27 UTC 2011
On 05/16/2011 07:18 PM, Michael Schroeder wrote:
> This patch adds support for a new fileattrs flag, "magic_and_path".
> Normally files get fed into the dependency helper if either the
> path regexp or the magic regexp matches. With the flag, both
> have to match.
> (If you don't like the name, feel free to choose a better one.)
Heh. The biggest reason this functionality (which is indeed quite
necessary) wasn't in rpm 4.9.0 was lack of a good name :)
I could easily live with "magic_and_path", but I think we'd want similar
switch for excludes too, and there it'll get a bit clumsy with
"exclude_magic_and_path" or such. One possibility would be adding a
separate exclude_flags and then "magic_and_path" would fit there as well.
- Panu -
More information about the Rpm-maint