[Rpm-maint] PATCH 1/2013 Take rid of redefinitions of __BEGIN_DECLS and __END_DECLS
pmatilai at laiskiainen.org
Mon Aug 19 12:17:11 UTC 2013
On 08/16/2013 03:26 PM, Kamil Rytarowski wrote:
> Yes, this looks better to introduce, into the RPM code. But as it's
> already defined by C libraries, I would use another names, like
> RPM_BEGIN_DECLS and RPM_FUN_PROTOTYPE.
> What do you think?
As for the prototype part, adding preprocessor goo for pre-ANSI C
compiler compatibility makes no sense whatsoever, rpm explicitly
requires a C99 compiler since several years.
As for RPM_BEGIN_DECLS/RPM_END_DECLS, those already exist but not
actually used... simply because nobody has bothered switching all the
headers to include and use the variants from <rpm/rpmutil.h> :)
- Panu -
More information about the Rpm-maint