[Rpm-maint] (no subject)

Mark Wielaard mark at klomp.org
Thu Jun 29 11:26:23 UTC 2017


Hi Panu,

On Mon, 2017-06-26 at 14:01 +0300, Panu Matilainen wrote:
> Please do the refactor to helper function(s) in a separate patch from 
> the rest of the changes, it'll be easier to review and bisect too if it 
> ever comes to that.

OK, the following patchset first adds the helper functions and then uses
them for the build-id file list generation.

> mkattr() with non-NULL fn argument ceases to be meaningful here, and 
> since it's not even used for anything, whether the mode should be 644 or 
> 755 nobody knows, certainly not that function. Better just drop 
> non-defattr case from it entirely.

Right. But in that case we can just remove the fn argument completely.
I added it as a separate patch.

[PATCH 1/3] Extract package file list processing in separate functions.
[PATCH 2/3] Use a file list to add build-id files to pkgList.
[PATCH 3/3] Change mkattr to always create a %defattr with explicitly

Cheers,

Mark


More information about the Rpm-maint mailing list