[Rpm-maint] rpm4.14 makes perl-RPM4 testsuite to segfault

Thierry Vignaud thierry.vignaud at gmail.com
Thu Oct 5 13:36:55 UTC 2017

On 5 October 2017 at 14:07, Igor Gnatenko
<ignatenkobrain at fedoraproject.org> wrote:
>> For the record
>> BTW, the latest issue I've with rpm-4.14 is that its testsuite has
>> several debugsources related failures  when building it with rpm-4.14
>> tpoo
>> http://pkgsubmit.mageia.org/uploads/done/cauldron/core/release/201710
>> 05114000.tv.duvel.20120/rpm-4.14.0-
>> 0.rc2.4.mga7/build.0.20171005114003.log
>> Have you tried building rpm-4.14 with rpm-4.14?
> I think the problem is that you have enabled producing debugsource in
> RPM while we have it in redhat-rpm-config in Fedora. I've seen same
> failures when I tried to enable debugsource packages directly in RPM...

It's not enabled in rpm but it is in the pkg equivalent to
redhat-rpm-config (rpm-mageia-setup), which is installed by default in
build chroots
After all we do want rpm-debugsource
Also di

More information about the Rpm-maint mailing list