<br><br><div class="gmail_quote"><div style="margin-left: 80px;">On Fri, May 23, 2008 at 12:27 AM, Linda Walsh &lt;<a href="mailto:rpm@tlinx.org">rpm@tlinx.org</a>&gt; wrote:<br><br>
Florian Festi wrote:<br></div>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 12.8ex; padding-left: 1ex;">
holmes86 wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Appear error message &quot;Failed dependencies&quot; When I install rpm package with --aid option under FC8.<br>
why?<br>
</blockquote></blockquote><div style="margin-left: 80px;">
--- &nbsp; Hey holmes, I&#39;d sorta like to know that too...:-)<br><br></div>

<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 12.8ex; padding-left: 1ex;">
Don&#39;t do that. --aid is no longer supported (the database used to<br>
resolve the dependencies is no longer shipped) and this feature is not<br>
working well anyway and will removed from future versions of rpm.<br>
</blockquote><div style="margin-left: 80px;">
----<br></div><div style="margin-left: 80px;">.......<br>
 &nbsp;Does &#39;rpm&#39; read the user&#39;s ~/.rpmmacros file in addition to the<br>
machine&#39;s /etc/rpm/macros file? &nbsp;&quot;rpm-cache&quot; appears to<br>
use the values in ~/.rpmmacros<br><br></div>


<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 12.8ex; padding-left: 1ex;">
Use &quot;yum install foo&quot; instead. Yum is working on the packages actual<br>
available and is able to download them on demand. It is also possible to<br>
give rpm files to the yum command line.<br>
</blockquote><div style="margin-left: 80px;">
----<br><br></div>

<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 12.8ex; padding-left: 1ex;">
&nbsp;yum install foo<br>
</blockquote><div style="margin-left: 80px;">
: [Errno 4] IOError: &lt;urlopen error (101, &#39;Network is unreachable&#39;)&gt;<br>
Trying other mirror.<br>
Error: Cannot retrieve repository metadata (repomd.xml) for repository: %s. Please verify its path and try again<br>
------<br>
 &nbsp;yum doesn&#39;t appear to understand the rpm macros file. Are you sure<br>
it is supposed to work with the rpm commands and databases? &nbsp;Is it<br>
even compatible with the rpm data and macro files?&nbsp; <br></div><br>for the compatibility questions, yum use the rpm-python api in large part. For the repo and the like look to the yum docu. In RHEL5 yum is default installed and exists yum-rhn-plugin for contacting the rhn repo trasparently. <br>
<br>hth<br><div style="margin-left: 40px;"><br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>
_______________________________________________<br>
Rpm-maint mailing list<br>
<a href="mailto:Rpm-maint@lists.rpm.org" target="_blank">Rpm-maint@lists.rpm.org</a><br>
<a href="https://lists.rpm.org/mailman/listinfo/rpm-maint" target="_blank">https://lists.rpm.org/mailman/listinfo/rpm-maint</a><br>
</blockquote></div><br>