This patch ported (mainly;) from <a href="http://rpm5.org">rpm5.org</a> HEAD fixes some api breakages<br>due to change done for the xz beta release (which the api of should be stable<br>now), add support for new xz payload in parallel with lzma payload and also<br>
sets the feature provides and requires for lzma payload to versions so that<br>compatibility with suse, mandriva &amp; <a href="http://rpm5.org">rpm5.org</a> is properly taken care of.<br><br><a href="http://proyvind.net/~peroyvind/rpm/rpm-4.7.0-lzdio-xzdio-parallel.patch">http://proyvind.net/~peroyvind/rpm/rpm-4.7.0-lzdio-xzdio-parallel.patch</a><br>
<br>The xz format is now frozen and considered stable, so for anyone who<br>wants to start adopting it, it should now be safe. :)<br><br>same patches for rpm 4.6.0 from mandriva svn:<br><a href="http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/rpm/current/SOURCES/rpm-4.6.0-rc1-compat-PayloadIsLzma.patch?view=log">http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/rpm/current/SOURCES/rpm-4.6.0-rc1-compat-PayloadIsLzma.patch?view=log</a><br>
<a href="http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/rpm/current/SOURCES/rpm-4.6.0-rc3-xz-support.patch?view=log">http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/rpm/current/SOURCES/rpm-4.6.0-rc3-xz-support.patch?view=log</a><br>
<br>jnovy: sorry for my laziness and delay ;p<br>--<br>Regards,<br>Per Řyvind<br>