<p>Coming from <a href="https://bugzilla.redhat.com/show_bug.cgi?id=1389871">https://bugzilla.redhat.com/show_bug.cgi?id=1389871</a></p>
<p>Unfortunately, rich dependencies do not help with that as pointed in one of comments:</p>
<pre><code># rpm -i bar-1-1.fc25.remi.noarch.rpm 
error: Failed dependencies:
        ((foo >= 2) and (foo <= 3)) is needed by bar-1-1.fc25.remi.noarch

# rpm -i foo1-1-1.fc25.remi.noarch.rpm 
# rpm -q --provides foo1
foo = 1
foo1 = 1-1.fc25.remi

# rpm -i foo4-4-1.fc25.remi.noarch.rpm 
# rpm -q --provides foo4
foo = 4
foo4 = 4-1.fc25.remi

# pm -ivh bar-1-1.fc25.remi.noarch.rpm 
Preparing...                          ################################# [100%]
Updating / installing...
   1:bar-1-1.fc25.remi                ################################# [100%]
</code></pre>
<p>Last command works, when we expect a way to disallow it.</p>
<p>The point why I raise it here is that in Rust packaging we are blocked by this, because each package has it's own version range which means you never can get multiple versions of same crate to be installed (because they are in Conflicts now).</p>

<p style="font-size:small;-webkit-text-size-adjust:none;color:#666;">—<br />You are receiving this because you are subscribed to this thread.<br />Reply to this email directly, <a href="https://github.com/rpm-software-management/rpm/issues/159">view it on GitHub</a>, or <a href="https://github.com/notifications/unsubscribe-auth/ANb801mN2e4BN2td3cQlIB4lVesy3T2Rks5reAMxgaJpZM4MFZxo">mute the thread</a>.<img alt="" height="1" src="https://github.com/notifications/beacon/ANb804Q3xXz_i1otiga3pZ28-WRJVEJdks5reAMxgaJpZM4MFZxo.gif" width="1" /></p>
<div itemscope itemtype="http://schema.org/EmailMessage">
<div itemprop="action" itemscope itemtype="http://schema.org/ViewAction">
  <link itemprop="url" href="https://github.com/rpm-software-management/rpm/issues/159"></link>
  <meta itemprop="name" content="View Issue"></meta>
</div>
<meta itemprop="description" content="View this Issue on GitHub"></meta>
</div>

<script type="application/json" data-scope="inboxmarkup">{"api_version":"1.0","publisher":{"api_key":"05dde50f1d1a384dd78767c55493e4bb","name":"GitHub"},"entity":{"external_key":"github/rpm-software-management/rpm","title":"rpm-software-management/rpm","subtitle":"GitHub repository","main_image_url":"https://cloud.githubusercontent.com/assets/143418/17495839/a5054eac-5d88-11e6-95fc-7290892c7bb5.png","avatar_image_url":"https://cloud.githubusercontent.com/assets/143418/15842166/7c72db34-2c0b-11e6-9aed-b52498112777.png","action":{"name":"Open in GitHub","url":"https://github.com/rpm-software-management/rpm"}},"updates":{"snippets":[{"icon":"DESCRIPTION","message":"Version range dependency (#159)"}],"action":{"name":"View Issue","url":"https://github.com/rpm-software-management/rpm/issues/159"}}}</script>