<p><a href="https://github.com/n3npq" class="user-mention">@n3npq</a>, thanks for your comments.</p>
<p>It's just to add more info:<br>
A possible conflict between package generated by rpm5 x rpm4 was one of our first hypothesis, however the same issue happens with signed packages generated by rpm4 (for the yocto-2.3 based system):</p>
<pre><code>bash-4.3# rpm5 -qp --yaml intel-aero-repo-1.4-r0.corei7_64.rpm | grep Rpmversion
  Rpmversion: 4.13.90
</code></pre>
<p>rpm 4 with the commit linked by <a href="https://github.com/lucasdemarchi" class="user-mention">@lucasdemarchi</a> above fails with the the following error:</p>
<pre><code>bash-4.3# rpm -qlp intel-aero-repo-1.4-r0.corei7_64.rpm 
error: intel-aero-repo-1.4-r0.corei7_64.rpm: signature region 62: tag number mismatch 8 ril 6 dl 4772 rdl 16

error: intel-aero-repo-1.4-r0.corei7_64.rpm: not an rpm package (or package manifest)
</code></pre>
<p>Both <a href="https://github.com/rpm-software-management/rpm/files/1166904/intel-aero-repo-1.4-r0.corei7_64.rpm.zip">intel-aero-repo</a> package and the <a href="https://github.com/rpm-software-management/rpm/files/1166908/public-gpg-key.txt">public key</a> are attached for reference.</p>

<p style="font-size:small;-webkit-text-size-adjust:none;color:#666;">—<br />You are receiving this because you are subscribed to this thread.<br />Reply to this email directly, <a href="https://github.com/rpm-software-management/rpm/issues/270#issuecomment-317133187">view it on GitHub</a>, or <a href="https://github.com/notifications/unsubscribe-auth/ANb803tgkyXm7qo2n-hUK7ABVD6OHoDPks5sQTDogaJpZM4Oeptu">mute the thread</a>.<img alt="" height="1" src="https://github.com/notifications/beacon/ANb80-qKO0Omjazm5JvDDcmDHyibP9d3ks5sQTDogaJpZM4Oeptu.gif" width="1" /></p>
<div itemscope itemtype="http://schema.org/EmailMessage">
<div itemprop="action" itemscope itemtype="http://schema.org/ViewAction">
  <link itemprop="url" href="https://github.com/rpm-software-management/rpm/issues/270#issuecomment-317133187"></link>
  <meta itemprop="name" content="View Issue"></meta>
</div>
<meta itemprop="description" content="View this Issue on GitHub"></meta>
</div>

<script type="application/json" data-scope="inboxmarkup">{"api_version":"1.0","publisher":{"api_key":"05dde50f1d1a384dd78767c55493e4bb","name":"GitHub"},"entity":{"external_key":"github/rpm-software-management/rpm","title":"rpm-software-management/rpm","subtitle":"GitHub repository","main_image_url":"https://cloud.githubusercontent.com/assets/143418/17495839/a5054eac-5d88-11e6-95fc-7290892c7bb5.png","avatar_image_url":"https://cloud.githubusercontent.com/assets/143418/15842166/7c72db34-2c0b-11e6-9aed-b52498112777.png","action":{"name":"Open in GitHub","url":"https://github.com/rpm-software-management/rpm"}},"updates":{"snippets":[{"icon":"PERSON","message":"@anselmolsm in #270: @n3npq, thanks for your comments.\r\n\r\nIt's just to add more info:\r\nA possible conflict between package generated by rpm5 x rpm4 was one of our first hypothesis, however the same issue happens with signed packages generated by rpm4 (for the yocto-2.3 based system):\r\n\r\n```\r\nbash-4.3# rpm5 -qp --yaml intel-aero-repo-1.4-r0.corei7_64.rpm | grep Rpmversion\r\n  Rpmversion: 4.13.90\r\n```\r\n\r\n\r\nrpm 4 with the commit linked by @lucasdemarchi above fails with the the following error:\r\n```\r\nbash-4.3# rpm -qlp intel-aero-repo-1.4-r0.corei7_64.rpm \r\nerror: intel-aero-repo-1.4-r0.corei7_64.rpm: signature region 62: tag number mismatch 8 ril 6 dl 4772 rdl 16\r\n\r\nerror: intel-aero-repo-1.4-r0.corei7_64.rpm: not an rpm package (or package manifest)\r\n```\r\n\r\nBoth [intel-aero-repo](https://github.com/rpm-software-management/rpm/files/1166904/intel-aero-repo-1.4-r0.corei7_64.rpm.zip) package and the [public key](https://github.com/rpm-software-management/rpm/files/1166908/public-gpg-key.txt) are attached for reference.\r\n"}],"action":{"name":"View Issue","url":"https://github.com/rpm-software-management/rpm/issues/270#issuecomment-317133187"}}}</script>